Re: what's wrong with the windows ncl installation?

From: Mary Haley <haley_at_nyahnyahspammersnyahnyah>
Date: Thu, 2 Nov 2006 10:37:09 -0700 (MST)

Hi Xuguang,

The error message:

  warning:GKS:GOPWK: --X driver error: error opening display

is indicating that DISPLAY is not set. Did you setenv your DISPLAY
environment variable as instructed on the same page at:

    http://www.ncl.ucar.edu/Download/cygwin.shtml#SetUpDisplay

Secondly, you also need to make sure you are running the above command
from a Cygwin/X window, and not just a Cygwin window. These are two
different things. There are instructions on opening a Cygwin/X window
on the same page at:

   http://www.ncl.ucar.edu/Download/cygwin.shtml#RunCygwinX

Good luck,

--Mary

On Fri, 3 Nov 2006, Xuguang Sun wrote:

> I've installed NCL in windows system step by step
> according to the installation document listed in the
> website
> "http://www.ncl.ucar.edu/Download/cygwin.shtml",
> however, when I try to test the ncl by the command
> "ncl < xy04n.ncl", there apprear some errors like the
> followings,
>
> Copyright (C) 1995-2006 - All Rights Reserved
> University Corporation for Atmospheric Research
> NCAR Command Language Version 4.2.0.a034
> The use of this software is governed by a License
> Agreement.
> See http://www.ncl.ucar.edu/ for more details.
> warning:GKS:GOPWK: --X driver error: error opening
> display
>
> warning:GKS:GESC: --SPECIFIED WORKSTATION IS NOT OPEN
>
> fatal:Workstation with PID#8 is not open
>
> fatal:Unable to open Workstation-Can't Create
>
> fatal:Unable to access object with id:-4
>
> fatal:_NhlCreate:Invalid Parent id #-4
>
> fatal:NhlDraw: Invalid Layer Id: -4
>
> fatal:Unable to update Workstation with PID#-4
>
> fatal:Unable to clear Workstation with PID#-4
>
> fatal:Execute: Error occurred at or near line 120
>
> I'm puzzled about this errors since there is no error
> during the installation. And I've successfully set the
> environmental variables in the .bashrc file, like
>
> export NCARG_ROOT=/usr/local
> export PATH=/usr/local/bin:$PATH
> export DISPLAY=:0.0
>
> so what's wrong about my ncl in windows system with
> cgywin/x installed?
>
> thanks a lot in advance.
>
> best regards,
>
>
>
> SUN Xuguang
> Department of Atmospheric Sciences
> 22 Hankou Road, Nanjing University, 210093
> Nanjing, P.R.China
>
>
>
> ___________________________________________________________
> עŻ-3.5G20M
> http://cn.mail.yahoo.com
> _______________________________________________
> ncl-talk mailing list
> ncl-talk_at_ucar.edu
> http://mailman.ucar.edu/mailman/listinfo/ncl-talk
>

_______________________________________________
ncl-talk mailing list
ncl-talk_at_ucar.edu
http://mailman.ucar.edu/mailman/listinfo/ncl-talk
Received on Thu Nov 02 2006 - 10:37:09 MST

This archive was generated by hypermail 2.2.0 : Thu Nov 02 2006 - 16:23:51 MST