Re: [ncarg-talk] running idt under cygwin

From: Joe Crepeau <jcrepeau_at_nyahnyahspammersnyahnyah>
Date: Wed, 24 Jun 2009 15:48:55 +0000


        Based on your comments, I remember now that my solution in the past was to use the pre-compiled binaries for idt and ictrans because I was unable to get them to build properly. I downloaded the precompiled binaries and tried them, but I get the same behavior. This is starting to look like a CYGWIN problem. How up-to-date is your CYGWIN installation? I assume that you are not experiencing the same problem. Any suggestions at this point?

        ictrans works just fine. ctrans works but hangs when I get to the end of the gmeta file and I have to kill the process in another window.

        While I have your attention, I have also noticed that when I moved from a single-core PC to a dual core that every so often, the build of ncarg will hang at different places in the build process. Have you encountered this problem before? I never had the problem on a single-core machine.


-----Original Message-----
From: Mary Haley []
Sent: Tuesday, June 23, 2009 10:05 PM
To: Joe Crepeau;
Subject: Re: [ncarg-talk] running idt under cygwin

Hi Joe,

I haven't seen this problem, but then, I'm still using g77 under
I think I had too many problems with gfortran.

One thing you could try is to just rebuild "idt" and "ictrans" with
g77/gcc V3.x and see if this makes a difference.

Also, you could try downloading the precompiled Cygwin
binary just for the "idt" and "ictrans" binaries and try them out.

"ictrans" is used by "idt"; that's why they are mentioned together.

Are you able to run ictrans, by any chance?

ictrans gmeta
ictrans> 1p
ictrans> quit


On Tue, 23 Jun 2009 23:31:09 +0000
  Joe Crepeau <> wrote:
> Hi,
> Recently I updated CYGWIN on my PC and idt no longer
>works properly. I can start idt, but if I click the play button or
>relocate the display window, idt crashes. Interestingly, if I resize
>the window first, it appears to work fine. I just can't move the
> I tried rebuilding the NCARG library (version 5.1.1)
>under the new CYGWIN installation, but I continue to have the same
>problem. I am using gfortran 4.3.0. Is this an NCARG problem or is
>it a CYGWIN problem? Have you seen this before?
> One note, in order to get idt to build properly I have to copy a
>file called "lex.yy_linux.c", which Mary gave me a while back, into
>the $NCARG/ncarview/src/lib/libictrans/lec.yy.c and do a "make all
>install" in there and in the ../../bin/ictrans directory. If I
>don't, I get an error that looks like this:
> ../../../.././ncarview/src/lib/libictrans/libictrans.o:lex_stuff.c:(.text+0x46fc):
>undefined reference to `_yylsp'
> Could this be causing the problem?
> Thanks,
> Joe
> ****************************
> Joseph Crepeau
> Computational Physics Group Leader
> Applied Research Associates, Inc.
> 4300 San Mateo Blvd. NE
> Suite A-220
> Albuquerque, NM 87110-1295
> (505) 816-6337 (P)
> (505) 872-0794 (F)
> ****************************

ncarg-talk mailing list
Received on Wed Jun 24 2009 - 09:48:55 MDT

This archive was generated by hypermail 2.2.0 : Thu Jun 25 2009 - 06:30:15 MDT