Re: NCL 5.1.1 seg fault when drawing maps

From: Adam Davis <adamdavi_at_nyahnyahspammersnyahnyah>
Date: Tue, 21 Jul 2009 18:09:30 -0400

Dear Mary,

With the new executable, everything is working fine. Thank you very much for your help!


Adam Davis
BSE Earth System Science and Engineering - Meteorology 2010
Dept. of Atmospheric Oceanic and Space Sciences
University of Michigan - Ann Arbor

Quoting Mary Haley <>:

> Hi Adam,
> A few people have had trouble with the Cygwin "ncl.exe" binary because
> of stack size issues.
> I created a new ncl.exe binary that has worked for some folks. If you
> want to give it a try, it's on anonymous ftp:
> ftp
> <log in as "anonymous">
> <Use email address as password>
> cd /pub/scd/haley
> get ncl_new.exe
> quit
> Once you have the file, gunzip it, make sure it is executable, and
> move it to $NCARG_ROOT/bin:
> gunzip ncl_new_exe.gz
> chmod gou+x ncl_new.exe
> mv ncl_new.exe $NCARG_ROOT/bin/.
> Now you can use this new NCL executable instead of the one already
> installed on your system:
> ncl_new.exe your_script.ncl
> If this works, you can replace your old ncl executable with this new
> one. You should first make a copy of your old one:
> mv $NCARG_ROOT/bin/ncl.exe $NCARG_ROOT/bin/ncl_old.exe
> mv $NCARG_ROOT/bin/ncl_new.exe $NCARG_ROOT/bin/ncl.exe
> ----------------------------------------------------------------------
> If this new executable doesn't work, then it would help if I could get
> your exact script and data. There's a special resource that you can
> set, and it will write out only the data I need to run your script:
> res_at_gsnDebugWriteFileName = "narrbug"
> Rerun your script with this resource, and it should create
> "narrbug.ncl" and "". If you can email me these, then I'll
> give them a try here.
> Thanks,
> --Mary
> On Mon, 20 Jul 2009, Adam Davis wrote:
>> Dear NCL users,
>> When I run a script that involves creating a map plot using NCL
>> 5.1.1, execution terminates with a segmentation fault at the point
>> where the map is drawn. For instance, when I run the second NARR
>> example script
>> ([1]) with the
>> -x option, the script executes normally until the "plot =
>> gsn_csm_contour_map..." line, where a segmentation fault occurs.
>> The segmentation fault also occurs with version 5.1.1 in several
>> other scripts that I have written that draw maps, which all worked
>> correctly with version 5.0.0 (I don't know about version 5.1.0,
>> though). These scripts use a few different gsn_csm map functions
>> (gsn_csm_contour_map, gsn_csm_vector_scalar_map, and gsn_csm_map),
>> all of which seem to have this issue. I suspect that the problem is
>> occurring when the map is drawn because in a couple of these
>> scripts, I set gsnDraw and gsnFrame to False, then call a map
>> function, add polymarkers and text to the maps, and finally call
>> draw and frame to create the output, and running these scripts with
>> the -x option reveals that the segmentation fault doesn't occur
>> until the first call of draw. I have not encountered any problems
>> drawing XY plots or the like with version 5.1.1 - just maps.
>> I am running NCL version 5.1.1 on Windows Vista SP1 under Cygwin/X
>> (uname -a outputs CYGWIN_NT-6.0 srbwks45150-01 1.5.25(0.156/4/2)
>> 2008-03-05 19:27 i686 Cygwin), although the same problem also arises
>> on my laptop running version 5.1.1 on Windows XP SP2 under Cygwin/X.
>> No warnings or errors are generated when this issue occurs besides
>> "Segmentation fault (core dumped)".
>> If you need any additional details about this issue (more example
>> scripts, stack traces, etc.), please let me know and I will be glad
>> to provide them. Thank you in advance for any help you can provide!
>> Sincerely,
>> Adam Davis
>> BSE Earth System Science and Engineering - Meteorology 2010
>> Dept. of Atmospheric Oceanic and Space Sciences
>> University of Michigan - Ann Arbor

Received on Tue Jul 21 2009 - 16:09:30 MDT

This archive was generated by hypermail 2.2.0 : Thu Jul 23 2009 - 08:02:42 MDT