Re: errors gotten from cygwin system

From: Straub, Katherine <straubk_at_nyahnyahspammersnyahnyah>
Date: Tue, 15 Sep 2009 09:29:15 -0400

I had a similar problem, which the new ncl_new.exe file fixed. I had
just installed NCL on my PC via Cygwin, and everything seemed to go ok.
The test example xy04n.ncl ran fine. However, I was unable to run
example scripts that included any of the gsn_csm_map functions. I
received a "Segmentation fault (core dumped)" error message. Other
example scripts (without gsn_csm_map) were successful, though. The new
ncl_new.exe solves this problem.

Kathy Straub

-----Original Message-----
From: [] On
Behalf Of Mary Haley
Sent: Monday, September 14, 2009 12:27 PM
To: yinjinfang88
Cc: ncl-talk
Subject: Re: errors gotten from cygwin system

Dear Yin,

I don't believe I've seen this error before. It's suspicious that
"xy04n.ncl" works one time, and not another. This sounds like
a system problem.

Before we start debugging this, can you try downloading an improved
"ncl" binary for your system? To get the file:

       <log in as "anonymous">
       <Use email address as password>
       cd /pub/scd/haley
       get ncl_new.exe.gz

Once you have the file, gunzip it, make sure it is executable, and
move it to $NCARG_ROOT/bin:

       gunzip ncl_new_exe.gz
       chmod gou+x ncl_new.exe
       mv ncl_new.exe $NCARG_ROOT/bin/.

Now you can use this new NCL executable instead of the one already
installed on your system:

       ncl_new.exe your_script.ncl

If you are comfortable that this executable works, you can replace
your old ncl executable with this new one. You should first make a
copy of your old one:

      mv $NCARG_ROOT/bin/ncl.exe $NCARG_ROOT/bin/ncl_old.exe
      mv ncl_new.exe $NCARG_ROOT/bin/ncl.exe


On Sun, 13 Sep 2009, yinjinfang88 wrote:

> Hi All,
I run into trouble when I tried to run ncl scripts in cygwin system.
The command line is :
  ncl xy04n.ncl
Following in the errors I have get.

Copyright (C) 1995-2009 - All Rights Reserved
  University Corporation for Atmospheric Research
  NCAR Command Language Version 5.1.1
  The use of this software is governed by a License Agreement.
  See for more details.

I have reinstall my cygwin system, the "ncl xy04n.ncl" can work well.
When I try to run a ncl script such as "wrf_PressureLevel1.ncl
", gotten from
INTERP/wrf_PressureLevel.htm, the error redisplayed.
I thought that maybe the "wrf_PressureLevel1.ncl" is wrong. However,
when I attempt to run "ncl xy04n.ncl" again, I failed. The error was the
same as above mentioned.


Yin .J F.
ncl-talk mailing list
List instructions, subscriber options, unsubscribe:
ncl-talk mailing list
List instructions, subscriber options, unsubscribe:
Received on Tue Sep 15 2009 - 07:29:15 MDT

This archive was generated by hypermail 2.2.0 : Tue Sep 15 2009 - 16:03:21 MDT