Re: ncl-talk Digest, Vol 70, Issue 34

From: yinjinfang <yinjinfang88_at_nyahnyahspammersnyahnyah>
Date: Wed, 16 Sep 2009 16:50:44 +0800

Hi, Mary,
    I am sorry to trouble you again. I have downloaded the "ncl_new.exe" file. However, it did not solve the problem. The errors are all the same as before.

                                                        Yin J. F.



   5. Re: errors gotten from cygwin system (Mary Haley)
Message: 5
Date: Mon, 14 Sep 2009 10:27:10 -0600 (MDT)
From: Mary Haley <>
Subject: Re: errors gotten from cygwin system
To: yinjinfang88 <>
Cc: ncl-talk <>
Message-ID: <>
Content-Type: TEXT/PLAIN; charset=US-ASCII; format=flowed
Dear Yin,
I don't believe I've seen this error before. It's suspicious that
"xy04n.ncl" works one time, and not another. This sounds like
a system problem.
Before we start debugging this, can you try downloading an improved
"ncl" binary for your system? To get the file:
       <log in as "anonymous">
       <Use email address as password>
       cd /pub/scd/haley
       get ncl_new.exe.gz
Once you have the file, gunzip it, make sure it is executable, and
move it to $NCARG_ROOT/bin:
       gunzip ncl_new_exe.gz
       chmod gou+x ncl_new.exe
       mv ncl_new.exe $NCARG_ROOT/bin/.
Now you can use this new NCL executable instead of the one already
installed on your system:
       ncl_new.exe your_script.ncl
If you are comfortable that this executable works, you can replace
your old ncl executable with this new one. You should first make a
copy of your old one:
      mv $NCARG_ROOT/bin/ncl.exe $NCARG_ROOT/bin/ncl_old.exe
      mv ncl_new.exe $NCARG_ROOT/bin/ncl.exe
On Sun, 13 Sep 2009, yinjinfang88 wrote:
> Hi All,
I run into trouble when I tried to run ncl scripts in cygwin system.
The command line is :
  ncl xy04n.ncl
Following in the errors I have get.
Copyright (C) 1995-2009 - All Rights Reserved
  University Corporation for Atmospheric Research
  NCAR Command Language Version 5.1.1
  The use of this software is governed by a License Agreement.
  See for more details.
I have reinstall my cygwin system, the "ncl xy04n.ncl" can work well.
When I try to run a ncl script such as "wrf_PressureLevel1.ncl
", gotten from, the error redisplayed.
I thought that maybe the "wrf_PressureLevel1.ncl" is wrong. However, when I attempt to run "ncl xy04n.ncl" again, I failed. The error was the same as above mentioned.
                                                                                                           Yin .J F.

ncl-talk mailing list
List instructions, subscriber options, unsubscribe:
Received on Wed Sep 16 2009 - 02:50:44 MDT

This archive was generated by hypermail 2.2.0 : Wed Sep 16 2009 - 12:58:13 MDT