Running time error: dyld: lazy symbol binding failed: Symbol not found: ___emutls_get_address

From: Yu Cheng <fischcheng_at_nyahnyahspammersnyahnyah>
Date: Fri Aug 30 2013 - 16:03:43 MDT

Hi everyone,

Thanks for Dave's help, I successfully wrote a .plist to schedule a daily
job running NCL scripts. However, when I tried to implement the NCL scripts
i wrote on my laptop to a desktop, some error messages popped out:

dyld: lazy symbol binding failed: Symbol not found: ___emutls_get_address
  Referenced from: /Users/ihu/NCL/bin/ncl
  Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: ___emutls_get_address
  Referenced from: /Users/ihu/NCL/bin/ncl
  Expected in: /usr/lib/libSystem.B.dylib

Trace/BPT trap

I've googled a bit and found two treads of this topics, asked by the same
person, but no results if he actually solved it.

Generally, I have almost the same system setup as his Mac. OSX 10.6.8, gcc
4.2, gfortran 4.6,
gfortran installed by Homebrew, and gcc by the Xcode package, not under
same PATH (but on my laptop, the setting is just the same, except I have
OSX10.8.4). I've tried reinstalling XCODE, gcc, gfortran, homebrew, locate
the libSystem.B.dylib but couldn't solve this problem. I even upgrade my
NCL version to the latest 6.1.2.

What's more intriguing: I have two NCL scripts on this machine, one works
perfectly, another just doesn't. Tried to run on my laptop, two scripts can
generate plots without any problem. Even more mysterious, yesterday both
scripts did work on this desktop...

I didn't modify the scripts a lot except the PATH, when I implemented them
to this Desktop. Thank you for reading this, hope someone knows the

Yu Cheng

ncl-talk mailing list
List instructions, subscriber options, unsubscribe:
Received on Fri Aug 30 16:04:14 2013

This archive was generated by hypermail 2.1.8 : Wed Sep 04 2013 - 10:27:57 MDT