problems reading gsn_*.ncl with AIX

From: Maurice McHugh (mmchug4 AT XXXXXX)
Date: Mon Feb 17 2003 - 13:29:38 MST


Thanks for your help on Fridays question: sorry for pestering you once more!

(1) I've had ncl installed on an IBM RS6000 cluster running AIX.
Everything appeared to be ok until I tried loading the gsn_*.ncl files, the
shea_util.ncl and contributed.ncl files from the generic location (if I
recall correctly it's $NCARG_ROOT/lib/ncarg/nclscripts/csm/). The ncl
interpeter then gave me all kinds of non-fatal error messages related to
those files being read incorrrectly.

However - when using ncl from the command line the same files loaded without
any complaints from the ncl interpreter.

Intererestingly enough, another ncl user on the same system was able to use
the gsn_*.ncl code to produce a generic x-y plot using the same "load"
commands that fail when I try them.

I've tried loading the gsn_*.ncl scripts into different directories which I
own, and change permissions to no avail.

The following problem occurs on my server running red-hat linux:
(2) A second, and potentially related issue, occurs when I try to point the
NCL_DEF_SCRIPTS_DIR environmental variable to a directory containing the
latest versions of the gsn_*.ncl etc. files that I want to "auto-load" into
my scripts. I recieve all kinds of non-fatal complaints from the ncl
interpreter as in problem (1). This also fails when I point
NCL_DEF_SCRIPTS_DIR to the versions of the gsn*.ncl scripts installed in the
generic $NCARG_ROOT/lib etc location.

Any suggestions would be gratefully accepted, and implemented!


Maurice J. McHugh, Ph.D.
Department of Geography and Anthropology
Louisiana State University
Baton Rouge LA 70803

ncl-talk mailing list
ncl-talk AT

This archive was generated by hypermail 2b29 : Tue Feb 18 2003 - 07:54:39 MST